Installing Windows NT 4.0 on Qemu

From Computer History Wiki
Revision as of 14:41, 19 November 2010 by Neozeed (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Windows NT 4.0 is probably the easiest OS to install on Qemu. The video, sound and networking are all supported out of the box!

Windows NT 4.0 running on Qemu

Start by creating a hard disk image. Because Windows NT 4.0 starts with a fat16 partition (even if you select NTFS it still formats it fat16, then converts it on the 2nd boot..) I recommend that your first disk be 2GB as to not confuse the installer, as disks larger then 8GB will do so..

With service pack 6a NT 4.0 will easily use IDE disks upwards of 100GB.

So to create the 2GB image use the following command:

qemu-img create -f qcow NT4.disk 2G

Next it will depend if you have an ISO image of the NT 4.0 CD, or if you have the actuall media..

For an iso image

qemu -L . -hda NT4.disk -net nic,model=pcnet -net user -cpu pentium -soundhw all -cdrom "Windows NT 4.iso" -boot d

And for the CD-ROM

qemu -L . -hda NT4.disk -net nic,model=pcnet -net user -cpu pentium -soundhw all -cdrom \\.\d: -boot d

Once the CD has booted, go ahead let it format the disk, and install to the WINNT directory (or any other if you prefer)... Once it is ready to reboot, halt Qemu, and remove the "-boot d" prompt.. As you will no longer need it, and the NT 4.0 CD boots ALL THE TIME NO EXCEPTION...

NT 4.0 will support the AMD PCNet card, in version 0.13.0 pretty well. I've found that you must specify the CPU to be a pentium otherwise it'll blue screen on any Intel/AMD host.

The most awkward part of NT 4.0 is that for the first logon you have to press control alt delete, which is impossible on Windows hosts.. You have to do the contrl+alt+2 to change Qemu to the command window.. Then issue the command:

sendkey ctrl-alt-delete

Then hold the control+alt+1 keys, to get back to the GUI. Once NT 4.0 is first installed, I recommend that you fix NT 4.0 to autologin... See here. With that taken out of the way, the next thing I'd recommend is applying service pack 6, then setting up the sound (go to the control pannel, then music devices, add the sound blaster 16 1.x). With that out of the way, go ahead with Internet Explorer 6.0sp1...

I would also recommend installing the MP3 codec so you can play mp3's!

That is about it, NT 4.0 installs easily!