Domain Name System: Difference between revisions
m +cat |
Add prior host table, RFCs |
||
| Line 1: | Line 1: | ||
The '''Domain Name System''' (usually abbreviated to '''DNS''') is a [[distributed database]] which is used on the [[Internet]] to hold [[mapping]]s from human-readable names (such as '.COM') to [[binary]] [[address]]es. | The '''Domain Name System''' (usually abbreviated to '''DNS''') is a replicated [[distributed database]] which is used on the [[Internet]] to hold [[mapping]]s from human-readable names (such as '.COM') to [[binary]] [[address]]es. Before DNS, a [[file]] holding the mappings, the [[host table]], was used, but that clearly was not going to scale. | ||
The DNS is organized as a [[hierarchy]]; like [[file]] names in a hierarchical [[file system]], a complete DNS name consists of a number of parts, each one of which selects one of the | The DNS is organized as a [[hierarchy]]; like [[file]] names in a hierarchical [[file system]], a complete DNS name consists of a number of parts, each one of which selects one of the possible [[namespace]]s (sub-directories) at the next level down. The leaves of the tree usually name individual [[host]]s. | ||
Although the DNS has the capability to hold addresses for a number of different [[protocol suite]]s, in general it now only hold addresses for the [[Internet Protocol]]. | Although the DNS has the capability to hold addresses for a number of different [[protocol suite]]s, in general it now only hold addresses for the [[Internet Protocol]]. | ||
{{semi-stub}} | {{semi-stub}} | ||
==See also== | |||
* [[Request for Comments]] | |||
==External links== | |||
* [https://www.rfc-editor.org/info/rfc882 Domain Names - Concepts and Facilities] (RFC-882 - November, 1983) | |||
* [https://www.rfc-editor.org/info/rfc883 Domain Names - Implementation and Specification] (RFC-883 - November, 1983) | |||
* [https://www.rfc-editor.org/info/rfc973 Domain System Changes and Observations] (RFC-973 - January, 1986) | |||
* [https://www.rfc-editor.org/info/rfc1034 Domain Names - Concepts and Facilities] (RFC-1034 - November, 1987) | |||
* [https://www.rfc-editor.org/info/rfc1035 Domain Names - Implementation and Specification] (RFC-1035 - November, 1987) | |||
[[Category: Internet]] | [[Category: Internet]] | ||
Revision as of 19:46, 11 August 2023
The Domain Name System (usually abbreviated to DNS) is a replicated distributed database which is used on the Internet to hold mappings from human-readable names (such as '.COM') to binary addresses. Before DNS, a file holding the mappings, the host table, was used, but that clearly was not going to scale.
The DNS is organized as a hierarchy; like file names in a hierarchical file system, a complete DNS name consists of a number of parts, each one of which selects one of the possible namespaces (sub-directories) at the next level down. The leaves of the tree usually name individual hosts.
Although the DNS has the capability to hold addresses for a number of different protocol suites, in general it now only hold addresses for the Internet Protocol.
See also
External links
- Domain Names - Concepts and Facilities (RFC-882 - November, 1983)
- Domain Names - Implementation and Specification (RFC-883 - November, 1983)
- Domain System Changes and Observations (RFC-973 - January, 1986)
- Domain Names - Concepts and Facilities (RFC-1034 - November, 1987)
- Domain Names - Implementation and Specification (RFC-1035 - November, 1987)